VMware 1.0.6 + Kernel 2.6.25

Posted: June 4, 2008 in BlogBlurb, VMware

VMware 1.0.6 has been released (a few days ago). I had downloaded and installed in 2 systems, so far it seems working well, and it no longer need any additional patching in order to build with Linux kernel 2.6.25.x

However, it still using a deprecated or unused module API.

VMware: VMware Server

Advertisements
Comments
  1. Albert says:

    Hi

    I download vmware server 1.0.6 and server have kernel 2.6.25.4 , but vmware server it’s not compiled.

    Building for VMware Server 1.0.0.
    Using 2.6.x kernel build system.
    make: Wejście do katalogu `/tmp/vmware-config2/vmmon-only’
    make -C /lib/modules/2.6.25.4/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Wejście do katalogu `/var/lib/virtualki/linux-2.6.25.4′
    CC [M] /tmp/vmware-config2/vmmon-only/linux/driver.o
    CC [M] /tmp/vmware-config2/vmmon-only/linux/driverLog.o
    CC [M] /tmp/vmware-config2/vmmon-only/linux/hostif.o
    CC [M] /tmp/vmware-config2/vmmon-only/common/comport.o
    CC [M] /tmp/vmware-config2/vmmon-only/common/cpuid.o
    CC [M] /tmp/vmware-config2/vmmon-only/common/hash.o
    CC [M] /tmp/vmware-config2/vmmon-only/common/memtrack.o
    CC [M] /tmp/vmware-config2/vmmon-only/common/phystrack.o
    CC [M] /tmp/vmware-config2/vmmon-only/common/task.o
    cc1plus: warning: command line option “-Werror-implicit-function-declaration” is valid for C/ObjC but not for C++
    cc1plus: warning: command line option “-Wdeclaration-after-statement” is valid for C/ObjC but not for C++
    cc1plus: warning: command line option “-Wno-pointer-sign” is valid for C/ObjC but not for C++
    cc1plus: warning: command line option “-Wstrict-prototypes” is valid for Ada/C/ObjC but not for C++
    cc1plus: warning: command line option “-ffreestanding” is valid for C/ObjC but not for C++
    include/asm/page.h: In function ‘pte_t native_make_pte(pteval_t)’:
    include/asm/page.h:128: error: expected primary-expression before ‘)’ token
    include/asm/page.h:128: error: expected ‘;’ before ‘{‘ token
    include/asm/page.h:128: error: expected primary-expression before ‘.’ token
    include/asm/page.h:128: error: expected `;’ before ‘}’ token
    make[2]: *** [/tmp/vmware-config2/vmmon-only/common/task.o] Błąd 1
    make[1]: *** [_module_/tmp/vmware-config2/vmmon-only] Błąd 2
    make[1]: Opuszczenie katalogu `/var/lib/virtualki/linux-2.6.25.4′
    make: *** [vmmon.ko] Błąd 2
    make: Opuszczenie katalogu `/tmp/vmware-config2/vmmon-only’
    Unable to build the vmmon module.

  2. lenrek says:

    Something is wrong here, can you try install the vmware server again? Make sure you execute vmware-install.pl.

    I am using kernel 2.6.25.4 on 2 machines. No problem at all for installing VMware server 1.0.6

  3. Józef Wiora says:

    I have the same problem with the same list of errors after upgrading the kernel to 2.6.25.4-10.fc8-i686. I’m working with VMware Server 1.0.0 and the vmware-any-any-update-116.tgz. With the previous version of kernel 2.6.24.7-92.fc8 all have worked fine.

  4. lenrek says:

    Err… VMware Server 1.0.0? Can you try 1.0.6 instead of using 1.0.0?

  5. Adriano Vieira says:

    Hi, guys!

    I’ve installed debian with kernel-2.6.25 and also tried to install vmware_server-1.0.6, but I without success.

    – I’ve tried any-ny-115, any-any-117, any-any117-veryALPHA and (vmmon-2.6.25patch vmnet-2.6.25patch). I uninstalled vmware-server before apply each patch, off course 😉

    All those without success.

    We need your help.

    Thx in advance

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s