VMware Server 1.0.7 and Linux Kernel 2.6.26.x

Posted: August 31, 2008 in BlogBlurb, Linux, VMware

A new version of VMware Server 1.0.7 has been released. Sadly, it does not work with Linux 2.6.26.x series kernel.

From the Release Notes, it seems the changes from 1.0.6 to 1.0.7 are primary for security fixes. It does not address the issue of compatibility with Linux Kernel.

Fortunately, the patch files for 1.0.6 can be apply to 1.0.7 cleanly. I manage to build the latest VMware Server after applied the patches. Seems to work nicely.

Advertisements
Comments
  1. Daniel says:

    Thats right, but 2.6.27 and VMware does not work, which is really sad.

    Daniel

  2. lenrek says:

    Well, 2.6.27 is still in RC. So, we should not by hasty in using it.

    Unless, for your case, there is a need to run 2.6.27 (to support specific hardware, or need to use a particular feature only available in new kernel), you don’t have to upgrade to that kernel yet.

    I have some system in my installation that still using older kernel (before 2.6.26). They are production servers, upgrading of kernel is actually in a lesser priority list.

  3. vmdeb says:

    Hi Ienrek,

    I’ve been using the patch (which I found here in your blog a couple of weeks ago) in the 1.0.6 vmware server version running on 2.6.26.1 and it was working greatfuly. I use Debian Lenny.
    Although, I upgraded the kernel to 2.6.26.4. Since then, vmware stopped working. I tried reconfiguring (vmware-config.pl), by the way this process goes fine (no errors), but when I try to get it to work it shows a lot of errors.

    I’l try to apply the patch to the 1.0.7 sooner. I’ll check out virtualbox and see whether it’s good or not. Vmware is annoying me.

  4. lenrek says:

    You may want to post the error here.

    Maybe is some symbolic links you need to create, for pointing to the correct library files.

    By the way, is Lenrek, this name is simply the reverse spelling of the word kernel.

    Cheers!

  5. lenrek says:

    Thanks for the post, I will definitely check it out.

    Though, I think, this patch (if work) would only just delay my migration to VirtualBox…

  6. jcp says:

    Thanks for the article! The Patches work also with VMWare Server 1.0.8 and Debian lenny 2.6.26-1-686-bigmem

  7. david says:

    Thanks for the guide!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s